Pet forum for dogs cats and humans - Pets.ca

Pet forum for dogs cats and humans - Pets.ca (http://www.pets.ca/forum/index.php)
-   Gardening (http://www.pets.ca/forum/forumdisplay.php?f=49)
-   -   A couple of roses and my poppies (http://www.pets.ca/forum/showthread.php?t=53215)

chico2 June 12th, 2008 07:52 AM

A couple of roses and my poppies
 
3 Attachment(s)
Took these yesterday,2 of my roses are blooming,more to come and then of course my pretty poppies.

chico2 June 12th, 2008 07:56 AM

3 Attachment(s)
Here is another Clematis,the color does not show very well and then a plant I have no idea what it is,don't like it much either.
The flowers only open when the sun is shining.

aslan June 12th, 2008 07:58 AM

teehee, i recognize those pretty flowers... yup i can vouche for her, the clematis are much prettier than in the pics.

Love4himies June 12th, 2008 08:00 AM

Your roses are perfect, not a blemish :lovestruck:.
What do you use on them for pest control?

Lukka'sma June 12th, 2008 08:20 AM

Love your roses chico, and the poppies are beautiful. I have never grown poppies but some day would love a garden full of them
I'm gonna guess the last plant to be spiderwort, but I could be wrong:shrug:

Chris21711 June 12th, 2008 09:34 AM

Beautiful yellow rose Chico, pink one too, but I'm not into pink very much. The other plant, I think Lukka'sma is right, I had one and didn't like it either but have a girlfriend who takes all of my 'no like' plants :) My Poppies are the same colour, still haven't popped yet, I love them trouble is they don't last long

chico2 June 12th, 2008 04:15 PM

Lukkas mom,I think Spiderwort is what they are,I keep pulling them out,but they keep coming back.:yell:I'll leave them now,but when they start getting out of hand out they go.
Chris,I also have a few different shades of red roses and a white one,but they are not blooming yet.
As for keeping them bug-free,we have a pesticide ban in Oakville,but when I noticed aphids,I did spray and they are now gone.poor Aphids:cry:
I have more problems with fungus,nothing seems to work.


All times are GMT -5. The time now is 11:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.